Vai al contenuto


113 27166 <![CDATA[Far Funzionare Smswebgun Sotto Un Proxy..]]> 334889 22 Apr 2008 http://forum.smsclient.it/topic/27166-far-funzionare-smswebgun-sotto-un-proxy/?view=findpost&p=334889 ho installato smswebgun.. essendo in uno studentato ho la connessione protetta con un proxy server. la prima volta che l'ho installato ci sono riuscito a inviare qualche sms ma ultimamente non ci riesco proprio :ahah:

quale stringa devo inserire nel terminale?

questa:
echo export http_proxy=&#39;http&#58;//username&#58;password@ip&#58;porta&#39; >> ~/.bashrc

o questa:
export http_proxy=http&#58;//user&#58;pass@ip&#58;porta/

mi da sempre il 4. rosso, il che vuol dire che l'invio fallisce sempre!! ]]>
0 9457 0
335406 23 Apr 2008 http://forum.smsclient.it/topic/27166-far-funzionare-smswebgun-sotto-un-proxy/?view=findpost&p=335406 Ciao, hai seguito i passi che ho scritto nell'altro thread? ovvero testare wget?
1. prova cosi, apri il terminale, e prova a settare la stringa del proxy manualmente:
export http_proxy='

Please Login HERE or Register HERE to see this link!

'
(ovviamente metti le tue credenziali)
e prova wget www.google.com -O google.html
2. comunque,in un forum ho letto che sia da specificare il parametro "-proxy=on", quindi prova: wget www.google.com -O google.htm -proxy=on
3. usi firefox? non che non mi fidi di te, ma potresti controllare che l'username che hai impostato per navigare con firefox sia lo stesso che tenti di inserire?
4. curiosità mia: su synaptic firefox eccetera, dove l'hai impostato il proxy? potresti modificare le impostazioni e riscrivere la password? (cosi ci assicuriamo che sia giusta!)
ps. potresti pastarmi l'output di wget? ]]>
0 8321 0
336804 28 Apr 2008 http://forum.smsclient.it/topic/27166-far-funzionare-smswebgun-sotto-un-proxy/?view=findpost&p=336804
donato@donato-laptop&#58;~$ export http_proxy=&#39;http&#58;//ftullii&#58;appellava0@10.xxx.xxx.xxx&#58;3128&#39;
donato@donato-laptop&#58;~$ wget www.google.com -O google.htm -proxy=on
donato@donato-laptop&#58;~$

questo è il risultato ottenuto nel terminale...nulla di che direi...

per far funzionare firefox sono andato su MODIFICA> PREFERENZE> SCHEDA AVANZATE > RETE> IMPOSTAZIONI> CONNESSIONE MANUALE DEL PROXY inserendo i dati del proxy che so a memoria perchè li uso da 2 anni!!!

per il sistema in generale sono andato su SISTEMA>PREFERENZE>PROXY DI RETE e inserito tutti i dati del proxy con i dettagli che sono user e pass

per far funzionare synaptic ho dovuto fare questo:
-aprire synaptic e inserire in IMPOSTAZIONI > PREFERENZE > RETE i dati del proxy con i dettagli che sono user e pass. questo però non basta e ho dovuto fare un'altra cosa che riporto qui di seguito:
- aprire col comando
sudo gedit /etc/environment
e inserire la seguente stringa
http_proxy=&#34;http&#58;//user&#58;pass@10.xxx.xxx.xxx&#58;3128&#34;

ripeto che prima di reinstallare ubuntu ero riuscito a far funzionare sms web gun.. ora proprio non ci sto riuscendo. ]]>
0 9457 0
336865 29 Apr 2008 http://forum.smsclient.it/topic/27166-far-funzionare-smswebgun-sotto-un-proxy/?view=findpost&p=336865

donato@donato-laptop&#58;~$ export http_proxy=&#39;http&#58;//ftullii&#58;appellava0@10.xxx.xxx.xxx&#58;3128&#39;
donato@donato-laptop&#58;~$ wget www.google.com -O google.htm -proxy=on
donato@donato-laptop&#58;~$

questo è il risultato ottenuto nel terminale...nulla di che direi...

per far funzionare firefox sono andato su MODIFICA> PREFERENZE> SCHEDA AVANZATE > RETE> IMPOSTAZIONI> CONNESSIONE MANUALE DEL PROXY inserendo i dati del proxy che so a memoria perchè li uso da 2 anni!!!

per il sistema in generale sono andato su SISTEMA>PREFERENZE>PROXY DI RETE e inserito tutti i dati del proxy con i dettagli che sono user e pass

per far funzionare synaptic ho dovuto fare questo:
-aprire synaptic e inserire in IMPOSTAZIONI > PREFERENZE > RETE i dati del proxy con i dettagli che sono user e pass. questo però non basta e ho dovuto fare un'altra cosa che riporto qui di seguito:
- aprire col comando
sudo gedit /etc/environment
e inserire la seguente stringa
http_proxy=&#34;http&#58;//user&#58;pass@10.xxx.xxx.xxx&#58;3128&#34;

ripeto che prima di reinstallare ubuntu ero riuscito a far funzionare sms web gun.. ora proprio non ci sto riuscendo.


Ciao, il fatto che tu abbia aggiunte quella riga su /etc/environment, puo voler dire che non serve aggiungerla sul .bashrc. prova ad eliminarla e usare wget senza niente. (mi sa che dopo aver eliminato le righe, per rendere effettive le modifiche devi fare il logout e dinuovo il login) ]]>
0 8321 0
336997 29 Apr 2008 http://forum.smsclient.it/topic/27166-far-funzionare-smswebgun-sotto-un-proxy/?view=findpost&p=336997 dici di eliminare le righe che ho inserito in bashrc? perchè su environment la devo lasciare altrimenti non mi funziona piu' nulla!! ]]> 0 9457 0 337305 30 Apr 2008 http://forum.smsclient.it/topic/27166-far-funzionare-smswebgun-sotto-un-proxy/?view=findpost&p=337305 esatto, quelle nel bashrc puoi eliminarle perchè quel parametro dovrebbe funzionare sia per wget che per sinaptyic, solo che nel caso di wget le variabili venivano sostituite da quellen el bashrc ( spero ! ) ]]> 0 8321 0