Vai al contenuto


41 20933 <![CDATA[[plugin] At Terminal]]> 264945 18 Aug 2007 http://forum.smsclient.it/topic/20933-plugin-at-terminal/?view=findpost&p=264945 AT Terminal

Introduzione
AT Terminal è un plugin che vi consentirà di comunicare con un Modem inviando dei comandi AT e di ottenere la risposta del terminale.

Da Implementare
* Un report della risposta del terminale più dettagliato.

Installazione
1) Chiudete wwSmsClient se in esecuzione
2) Copiate il file "AT Terminal.dll" nella cartella Plugins di wwSmsClient.
3) Andate in Documenti
4) Dentro la cartella wwSmsClient aprite il file PluginDescriptor.xml e aggiungete questa riga:
<PluginDesc ptype=&#34;ftplugin.AT_Terminal.Main&#34; name=&#34;AT Terminal&#34; file=&#34;AT Terminal.dll&#34; disPos=&#34;10&#34; updUrl=&#34;http&#58;//www.smsclient.it/wwSmsClient/updates/plugins.php&#34; installed=&#34;true&#34; ver=&#34;1.2.0.0&#34; KeepOnLiteVer=&#34;true&#34; />

Ultima release
Versione: 1.2.0.0
Data: 19/08/2007

Allega File(s)

]]>
0 162 0
264950 18 Aug 2007 http://forum.smsclient.it/topic/20933-plugin-at-terminal/?view=findpost&p=264950 0 18659 0 264961 18 Aug 2007 http://forum.smsclient.it/topic/20933-plugin-at-terminal/?view=findpost&p=264961

AT Terminal è un plugin che vi consentirà di comunicare con un Modem inviando dei comandi AT e di ottenere la risposta del terminale.


E non so se ci sia qualche metodo che abbia bisogno di comunicazione seriale ma dubito :D ]]>
0 162 0
265018 19 Aug 2007 http://forum.smsclient.it/topic/20933-plugin-at-terminal/?view=findpost&p=265018 ]]> 0 0 265047 19 Aug 2007 http://forum.smsclient.it/topic/20933-plugin-at-terminal/?view=findpost&p=265047
ChangeLog
  • Alla disconnessione/connessione di un nuovo dispositivo la lista dei dispositivi viene aggiornata
  • Fix Generali
]]>
0 162 0
265557 20 Aug 2007 http://forum.smsclient.it/topic/20933-plugin-at-terminal/?view=findpost&p=265557 :o
lo provo e ti faccio sapere se si può pensionare hyper terminal :D ]]>
0 7886 0
277958 18 Sep 2007 http://forum.smsclient.it/topic/20933-plugin-at-terminal/?view=findpost&p=277958 :lol2: ]]> 0 6098 0 296251 20 Nov 2007 http://forum.smsclient.it/topic/20933-plugin-at-terminal/?view=findpost&p=296251 ovvero ho fatto tutta la procedura ma non trovo il plugin nel client ]]> 0 2761 0 296486 21 Nov 2007 http://forum.smsclient.it/topic/20933-plugin-at-terminal/?view=findpost&p=296486

installato come nella guida ma non va'....
ovvero ho fatto tutta la procedura ma non trovo il plugin nel client

vai su strumenti - plugins - scegli plugin
se hai seguito le istruzioni di installazione dovrebbe comparirti "AT Terminal" nella lista
se compare dovresti cliccare col tasto destro e scegliere Load... dovrebbe apparire :evil: ]]>
0 7886 0
296503 21 Nov 2007 http://forum.smsclient.it/topic/20933-plugin-at-terminal/?view=findpost&p=296503

vai su strumenti - plugins - scegli plugin
se hai seguito le istruzioni di installazione dovrebbe comparirti "AT Terminal" nella lista
se compare dovresti cliccare col tasto destro e scegliere Load... dovrebbe apparire :evil:

fatto ma non c'è...
mi daresti una mano?? ]]>
0 2761 0
296509 21 Nov 2007 http://forum.smsclient.it/topic/20933-plugin-at-terminal/?view=findpost&p=296509

fatto ma non c'è...
mi daresti una mano??

se nn c'è hai sbagliato procedura di installazione
hai modificato correttamente il PluginDescriptor? ]]>
0 7886 0
296511 21 Nov 2007 http://forum.smsclient.it/topic/20933-plugin-at-terminal/?view=findpost&p=296511

vai su strumenti - plugins - scegli plugin
se hai seguito le istruzioni di installazione dovrebbe comparirti "AT Terminal" nella lista
se compare dovresti cliccare col tasto destro e scegliere Load... dovrebbe apparire :evil:

@ matrix riedito dopo alcune prove non va'-
questo puo' essere dovuto al fatto che aggiungo la stringa

<PluginDesc ptype="ftplugin.AT_Terminal.Main" name="AT Terminal" file="AT Terminal.dll" disPos="10" updUrl="

Please Login HERE or Register HERE to see this link!

installed="true" ver="1.2.0.0" KeepOnLiteVer="true" />

al fil plug....descr html.....ma , appena apro il client questa modifica mi si annulla e il file mi torna all'origine.
come mai???? ]]>
0 2761 0
296513 21 Nov 2007 http://forum.smsclient.it/topic/20933-plugin-at-terminal/?view=findpost&p=296513 prova a cancellare tutto il contenuto di PluginDescriptor e a incollare questo (fai prima una copia di backup):
salva e apri smsclient.. dovrebbe apparire
<?xml version=&#34;1.0&#34; standalone=&#34;yes&#34;?>
<XMLPlugin xmlns=&#34;NS_XMLPlugin&#34;>
  <PluginDesc ptype=&#34;wwSmsClient.default_control.MainPlugin&#34; name=&#34;Welcome Page&#34; file=&#34;../SmsClient.exe&#34; disPos=&#34;0&#34; updUrl=&#34;&#34; installed=&#34;true&#34; ver=&#34;1.0.0.0&#34; KeepOnLiteVer=&#34;false&#34; />
  <PluginDesc ptype=&#34;GuiSend.SendPlugin&#34; name=&#34;Invia i tuoi sms&#34; file=&#34;guisend.dll&#34; disPos=&#34;1&#34; updUrl=&#34;http&#58;//www.smsclient.it/wwSmsClient/updates/plugins.php&#34; installed=&#34;true&#34; ver=&#34;1.0.0.0&#34; KeepOnLiteVer=&#34;true&#34; />
  <PluginDesc ptype=&#34;GuiMiscellaneous.MiscellaneousPlugin&#34; name=&#34;Rimanenti ed altre&#34; file=&#34;GuiMiscellaneous.dll&#34; disPos=&#34;6&#34; updUrl=&#34;http&#58;//www.smsclient.it/wwSmsClient/updates/plugins.php&#34; installed=&#34;true&#34; ver=&#34;1.0.0.0&#34; KeepOnLiteVer=&#34;false&#34; />
  <PluginDesc ptype=&#34;ClientPkg.Client&#34; name=&#34;Chat&#34; file=&#34;client.dll&#34; disPos=&#34;2&#34; updUrl=&#34;http&#58;//www.smsclient.it/wwSmsClient/updates/plugins.php&#34; installed=&#34;true&#34; ver=&#34;2.1.0.2&#34; KeepOnLiteVer=&#34;false&#34; />
  <PluginDesc ptype=&#34;GuiExplorer.IExplorerPlugin&#34; name=&#34;Internet Explorer&#34; file=&#34;guiexplorer.dll&#34; disPos=&#34;7&#34; updUrl=&#34;http&#58;//www.smsclient.it/wwSmsClient/updates/plugins.php&#34; installed=&#34;true&#34; ver=&#34;1.0.0.0&#34; KeepOnLiteVer=&#34;false&#34; />
  <PluginDesc ptype=&#34;RadioControl.RadioPlugin&#34; name=&#34;Radio&#34; file=&#34;radiocontrol.dll&#34; disPos=&#34;3&#34; updUrl=&#34;http&#58;//www.smsclient.it/wwSmsClient/updates/plugins.php&#34; installed=&#34;true&#34; ver=&#34;1.0.0.0&#34; KeepOnLiteVer=&#34;false&#34; />
  <PluginDesc ptype=&#34;Notifier.NotifierPlugin&#34; name=&#34;Sms Pianificati&#34; file=&#34;notifier.dll&#34; disPos=&#34;4&#34; updUrl=&#34;http&#58;//www.smsclient.it/wwSmsClient/updates/plugins.php&#34; installed=&#34;true&#34; ver=&#34;1.2.0.0&#34; KeepOnLiteVer=&#34;false&#34; />
  <PluginDesc ptype=&#34;GuiReport.ReportPlugin&#34; name=&#34;Report&#34; file=&#34;guireport.dll&#34; disPos=&#34;0&#34; updUrl=&#34;http&#58;//www.smsclient.it/wwSmsClient/updates/plugins.php&#34; installed=&#34;true&#34; ver=&#34;1.0.0.0&#34; KeepOnLiteVer=&#34;true&#34; />
  <PluginDesc ptype=&#34;wwSmsClient.errorlogging.PluginErrLogging&#34; name=&#34;Logger&#34; file=&#34;logger.dll&#34; disPos=&#34;1&#34; updUrl=&#34;http&#58;//www.smsclient.it/wwSmsClient/updates/plugins.php&#34; installed=&#34;true&#34; ver=&#34;1.0.0.0&#34; KeepOnLiteVer=&#34;false&#34; />
  <PluginDesc ptype=&#34;GUIPluginSelector.PSelectorPlugin&#34; name=&#34;Scegli Plugin&#34; file=&#34;GUIPluginSelector.dll&#34; disPos=&#34;-1&#34; updUrl=&#34;http&#58;//www.smsclient.it/wwSmsClient/updates/plugins.php&#34; installed=&#34;true&#34; ver=&#34;1.0.0.0&#34; KeepOnLiteVer=&#34;false&#34; />
  <PluginDesc ptype=&#34;SmsArchive.SmsArchivePlugin&#34; name=&#34;Modelli SMS&#34; file=&#34;SmsArchive.dll&#34; disPos=&#34;5&#34; updUrl=&#34;http&#58;//www.smsclient.it/wwSmsClient/updates/plugins.php&#34; installed=&#34;true&#34; ver=&#34;1.0.0.0&#34; KeepOnLiteVer=&#34;false&#34; />
  <PluginDesc ptype=&#34;Statistics.StatisticsPlugin&#34; name=&#34;Statistiche&#34; file=&#34;Statistics.dll&#34; disPos=&#34;2&#34; updUrl=&#34;http&#58;//www.smsclient.it/wwSmsClient/updates/plugins.php&#34; installed=&#34;true&#34; ver=&#34;1.0.0.0&#34; KeepOnLiteVer=&#34;false&#34; />
  <PluginDesc ptype=&#34;SmsClient4Mobile.SmsClient4MobilePlugin&#34; name=&#34;Client4Mobile&#34; file=&#34;SmsClient4Mobile.dll&#34; disPos=&#34;8&#34; updUrl=&#34;http&#58;//www.smsclient.it/wwSmsClient/updates/plugins.php&#34; installed=&#34;true&#34; ver=&#34;1.0.0.0&#34; KeepOnLiteVer=&#34;false&#34; />
  <PluginDesc ptype=&#34;WebServer.WebServerPlugin&#34; name=&#34;Sms4Web&#34; file=&#34;WebServer.dll&#34; disPos=&#34;9&#34; updUrl=&#34;http&#58;//www.smsclient.it/wwSmsClient/updates/plugins.php&#34; installed=&#34;true&#34; ver=&#34;1.0.0.0&#34; KeepOnLiteVer=&#34;false&#34; />
  <PluginDesc ptype=&#34;Updater.UpdatePlugin&#34; name=&#34;Aggiornamenti&#34; file=&#34;GUIUpdater.dll&#34; disPos=&#34;-1&#34; updUrl=&#34;http&#58;//www.smsclient.it/wwSmsClient/updates/plugins.php&#34; installed=&#34;true&#34; ver=&#34;1.0.0.0&#34; KeepOnLiteVer=&#34;true&#34; />
  <PluginDesc ptype=&#34;ftplugin.AT_Terminal.Main&#34; name=&#34;AT Terminal&#34; file=&#34;AT Terminal.dll&#34; disPos=&#34;10&#34; updUrl=&#34;http&#58;//www.smsclient.it/wwSmsClient/updates/plugins.php&#34; installed=&#34;true&#34; ver=&#34;1.2.0.0&#34; KeepOnLiteVer=&#34;true&#34; />
  <DocumentVer DocVer=&#34;1.1.0.20&#34; />
</XMLPlugin>
]]>
0 7886 0
296519 21 Nov 2007 http://forum.smsclient.it/topic/20933-plugin-at-terminal/?view=findpost&p=296519 non so' che fare
:evil: ]]>
0 2761 0
296522 21 Nov 2007 http://forum.smsclient.it/topic/20933-plugin-at-terminal/?view=findpost&p=296522

FATTO non appare e l'ultima riga dell' at terminal dopo il riavvio del client mi scompare di nuovo..
non so' che fare
:evil:

prova a sistemare quel file come ti ho detto, poi dagli i xmessi di sola lettura :D ]]>
0 7886 0
296555 21 Nov 2007 http://forum.smsclient.it/topic/20933-plugin-at-terminal/?view=findpost&p=296555

prova a sistemare quel file come ti ho detto, poi dagli i xmessi di sola lettura :evil:

come ...''''???
NEL SENSO che ho rifatto tutto sono andato in proprieta'è scelto sola lettura ma come risultato ho ottenuto un client sensa nemmeno un plugin ...
sicuramente sbaglio qualcosa..
ps c'èntra qualcosa il fatto che ho vista??? ]]>
0 2761 0
297601 26 Nov 2007 http://forum.smsclient.it/topic/20933-plugin-at-terminal/?view=findpost&p=297601

3) Andate in Documenti
4) Dentro la cartella wwSmsClient aprite il file PluginDescriptor.xml e aggiungete questa riga:


Forse stai modificando quello presente in Programmi/

Cmq al 100% non è un problema del SO poichè se il Client parte con tutti i suoi plugin di default dovrebbe farlo anche con tale plugin. :fire: ]]>
0 162 0
297671 26 Nov 2007 http://forum.smsclient.it/topic/20933-plugin-at-terminal/?view=findpost&p=297671

Forse modifichi il file PluginDescriptor.xml sbagliato.
Forse stai modificando quello presente in Programmi/

Cmq al 100% non è un problema del SO poichè se il Client parte con tutti i suoi plugin di default dovrebbe farlo anche con tale plugin. :fire:

fatto tutto ma non va'
.oramai ho perso le speranze :boh:
lho modificato sto file una 60 ina di volte ma appena apro il client torna come prima ]]>
0 2761 0
297679 26 Nov 2007 http://forum.smsclient.it/topic/20933-plugin-at-terminal/?view=findpost&p=297679 0 162 0 297700 26 Nov 2007 http://forum.smsclient.it/topic/20933-plugin-at-terminal/?view=findpost&p=297700 dategli un'occhiata.
oppure se potete uppatemi il vostro

Allega File(s)

]]>
0 2761 0